DLE 13.2 просит обновить PHP

Тема в разделе "DLE", создана пользователем Nikolay Nikolaevich, 3 сен 2019.

Информация :
Актуальная версия DataLife Engine 13.2
( DataLife Engine 13.2 | Скачать DataLife Engine 10.0-13.1 | Скачать 13.2 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 12.1 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Модераторы: killoff
  1. Nikolay Nikolaevich

    Nikolay Nikolaevich Постоялец

    Регистр.:
    9 дек 2014
    Сообщения:
    136
    Симпатии:
    6
    Centos 6.9
    Обновился на c DLE 9.5 до 13.2
    Сайт работает нормально.
    При обновдении DLE попросил обновить PHP до версии минимам 5.4 Обновил стоит 5.4.7 Все модули вроде как в наличии.

    Однако при входе в админку висит предупреждение

    Attention!
    Outdated version of PHP is installed. Some script functions will be unavailable with this PHP version. It is highly recommended to contact administration of your hosting to update your PHP version at least up to 5.3 version. You can download the latest version on the official site.

    Не знаю в чём там дело. Всё вроде работает, но проверить совсем всё не могу, потому спрошу. Чем может быть вызвано это предупреждение?
     
  2. Girl

    Girl Писатель

    Регистр.:
    25 дек 2018
    Сообщения:
    6
    Симпатии:
    0
    Обычное предупреждение, можно проигнорировать если все работает, но лучше установить последнюю доступную версию, ведь 5.4.7 вышла в релиз в 2012.
     
  3. maham

    maham Создатель Нарушитель

    Регистр.:
    5 сен 2015
    Сообщения:
    6
    Симпатии:
    0
    дле 13 верссии требует минимум 5.6 а оптимально 7,1
     
  4. LazyDev

    LazyDev Создатель

    Регистр.:
    4 мар 2019
    Сообщения:
    16
    Симпатии:
    3
    https://dle-news.ru/request.html
     
  5. Горбушка

    Горбушка Ищу её...

    Регистр.:
    2 май 2008
    Сообщения:
    3.384
    Симпатии:
    2.357
    Все врут... Даже официальные сайты... Я верю только коду:

    Screenshot_1.png
    Обычная ошибка в переводе... В русской версии поправили, в английской нет. Ну и в требованиях на сайте тоже забыли...
    Проверка выглядит так:
    PHP:
        if( version_compare($phpv'5.5''<') ) {
            echo 
    "<div class=\"alert alert-danger alert-styled-left alert-arrow-left alert-component\">{$lang['stat_phperror']}</div>";
        }
    Т.е. требуется PHP 5.5 и выше.

    А теперь вернёмся в реальность... 21 век на дворе, вышел RHEL 8, уже бету 8.1 вовсю обсуждают. CentOS тоже 8-ую обещает с дня на день... В начале сентября вышел 1-ый кандидат PHP 7.4...
    А вы сидите на 6-ом CentOS и PHP 5.3/5.4? Не хотите операционку обновить? А PHP ниже 7.1 вообще уже не поддерживаются сообществом php.net...

    P.s. никогда не любил форки... RHEL 8 вышел почти полгода назад, а CentOS всё никак... То же мнение у меня про Ubuntu... Сейчас не уверен как оно, но раньше Debian вышел, а Ubuntu догоняет полгода... И это, увы, вызвано не стабильностью...
     
    Последнее редактирование: 15 сен 2019 в 00:59