Помощь После переноса сайта кодировка не определяется автоматом

Тема в разделе "DLE", создана пользователем beep, 30 янв 2019.

Информация :
Актуальная версия DataLife Engine 13.2
( DataLife Engine 13.2 | Скачать DataLife Engine 10.0-13.1 | Скачать 13.2 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 12.1 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Модераторы: killoff
  1. beep

    beep Постоялец

    Регистр.:
    29 окт 2007
    Сообщения:
    291
    Симпатии:
    18
    Приветствую всех.

    Такое дело: перенес сайт на старом dle с одного хостинга на другой.
    Т.е. сделал бекап бд, упаковал все файлы в архив.
    В DNS выставил новые значения, спустя несколько часов на новом хостинге:
    - распаковал файлы;
    - создал новую бд в win1251, залил файл бекапа
    - настроил соединение с БД

    Сайт открывается, но в Хроме с нарушенной кодировкой, т.е. с кракозяблами. В коде страницы вижу:
    Код:
    <meta content="text/html; charset=windows-1251" http-equiv="content-type">

    В IE11 тоже открывается с кракозяблами. Но если выбрать "Кодировка-> Кириллица (Windows)", то страница отображается нормально до следующего перехода по ссылке.

    В .htaccess пробовал добавить AddDefaultCharset windows-1251 - не помогает...
    В engine/data/dbconfig.php присутствует
    Код:
    define ("COLLATE", "cp1251");

    Куда копать, ума не приложу, к DLE не притрагивался лет 5...
    Версия DLE 10

    PHP: 7.2.10-0ubuntu0.18.04.1
    MySQL: 5.7.25-0ubuntu0.18.04.2 MySQLi
     
  2. serGUCCI

    serGUCCI John Wick

    Регистр.:
    25 ноя 2012
    Сообщения:
    273
    Симпатии:
    135
    при выгрузке обращали внимание на то в какой кодировке выгружали?
     
  3. beep

    beep Постоялец

    Регистр.:
    29 окт 2007
    Сообщения:
    291
    Симпатии:
    18
    Да, выгружал в 1251.

    Да и думаю, если бы неправильно выгрузил, то смена кодировки в ие11 не помогла бы?
     
  4. Горбушка

    Горбушка Ищу её...

    Регистр.:
    2 май 2008
    Сообщения:
    3.380
    Симпатии:
    2.328
    Дабы не мучаться с кодировками - обновление на 13.1 и нет проблем - utf-8.
    Глобально нужен линк на сайт - посмотреть какие заголовки отдаёт сервер. И скорее всего писать хостеру о некорректной настройке сервера.

    Впрочем, хостинг на Ubuntu... Многое говорит о хостинге...